Shop Mobile More Submit  Join Login
XPS Tutorial- Adding Heads to New Bodies by aydean XPS Tutorial- Adding Heads to New Bodies by aydean
[DOWNLOAD or FULLVIEW for best results!]

As requested by *drakl0r, learn how to attach a head to a different body in XPS! I kept the descriptions in this tutorial short and to the point since I've been over most of this stuff in previous tutorials. It really is the same basic process each time. ^^ Also, if you have any questions or issues, feel free to ask, and I'll try to help if I can.

More XPS Tutorials by aydean!

{OTHER TUTORIALS}
For other tutorials relating to MeshModding in XPS, check out:
XNAaraL's Tutorials at TRF
Tutorials by *Lilacatz

{CREDITS}
HAIR ~ (forgot to credit it above, my bad!) Lucy Stillman by ~lips--like--morphine
HEAD ~ Jill REbirth by ~ItalianUtent
TORSO ~ Archaeologist Long Outfit Lara by ~HailSatana
LEGS ~ Jill Casual by ~LittleMissWesker
All models/characters/original textures (c) their respectable owners
XPS is a free program based off of Dusan's XNALara posing program.
XPS is coded by Dusan and XNAaraL.
Add a Comment:
 
:iconlonerevenger:
LoneRevenger Featured By Owner Aug 19, 2015  Hobbyist Traditional Artist
Hi, nice tutorial, but have a problem. My Xna doesn't want to save a head model (It happens only with one model, others are okay). There are two possible issues: 1) Not enough memory 2) missing file or kinda of that, but file is not missing. I don't know what to do. This the "problem" model: konradm96.deviantart.com/art/T…
Reply
:iconaydean:
aydean Featured By Owner Aug 19, 2015  Hobbyist Digital Artist
Hmm, I've played around with that model myself, and I haven't encountered any issues. :/ If it's the memory error, just close all other programs when working in XPS. That should free up enough RAM to help it out. I've never had a memory issues with XPS, so I doubt that's the cause, but still, it's better to eliminate all possibilities. 

The missing file error: what file is missing? If it's a texture, just save Lara's head and uncheck the option to copy all textures. Then manually copy and transfer the textures on your own. This trick will fix almost any texture issues. :] If it's a different file, like a .dds or .mesh, then try re-downloading his model (or consider getting that retextured Lara head from a different model). Missing DDS or mesh files usually require the original mod's help to correct. And since I haven't had any problems with his model, I'm guessing you've just run into a freak glitch.

If none of those options are working, try Googling for a link to an OLDER XPS (You should be able to find it on XNAaraL's website). Sometimes the newest edition acts a little weird with some models, so maybe an other version will be kinder to you. :]

Happy modding!
Reply
:iconlonerevenger:
LoneRevenger Featured By Owner Aug 22, 2015  Hobbyist Traditional Artist
Thank you a lot! I will try. :D
Reply
:iconunikraken2014:
UNIKRAKEN2014 Featured By Owner Jul 18, 2015
Hello. I'm still new to modding. But trying to learn. Please tell me. How to change skin color on the neck. To have identical colour of the head with the neck. www.screencapture.ru/uploaded/… I would be grateful for help.
Reply
:iconaydean:
aydean Featured By Owner Jul 18, 2015  Hobbyist Digital Artist
Editing any colors on the models requires a photo editing software, like Photoshop. This action is done outside of XPS.
Reply
:iconunikraken2014:
UNIKRAKEN2014 Featured By Owner Jul 18, 2015
Thank you very much. For the advice. Another question. And is there a way to make it through the Blender?
Reply
:iconaydean:
aydean Featured By Owner Jul 18, 2015  Hobbyist Digital Artist
Blender and I do not get along. I never managed to figure out the program myself, so I can't offer any help. But there are a LOT of tutorials out there. Search Google, here on dA, and most importantly, Blender.org's help section. 
Reply
:iconunikraken2014:
UNIKRAKEN2014 Featured By Owner Jul 18, 2015
uh... Sure:) thank you again:) But still you helped me. You showed me the right path.:) Yes even? Thanks for the lesson which is presented here. He well helped me:)
Reply
:iconjckspacy:
Jckspacy Featured By Owner Jul 1, 2015  Student Artist
Okay, I'm having a bit of a problem here. When ever I add the head it jumps straight to the legs of the body and attaches there. I followed your steps and even chose "Head Neck Upper' and when I click okay it jumps straight to the legs. Am I doing something wrong? 
Reply
:icongabi007:
gabi007 Featured By Owner Jun 9, 2015
recently i can't save any mesh mod i made on XNA. Everytime i tray it, i gives me error (could not save... index off limits)

how can i solve this?
Reply
:iconzapushkae:
Zapushkae Featured By Owner Apr 12, 2015  Hobbyist Traditional Artist
I did this and it works, however when I load the new model, only the head is left shiny. So when ever I try to use the "bump specular gloss" function it only works on the head and the body is left unshiny. 
Reply
:iconfatslacker:
FatSlacker Featured By Owner Edited Mar 20, 2015
Thanks for this tutorial. I've tried this a year ago and I still get the same result. I add a head and a neck to a body; result is seamless with no weight issues. But when I load the model, blam, the head's missing. I saved both the head and the body as a separate folder, I tried to copy all the textures of both into the folder with the generic mesh file in it as well but to no avail. Assistance is very much appreciated.
Reply
:iconaydean:
aydean Featured By Owner Mar 20, 2015  Hobbyist Digital Artist
First, don't fuss over the textures. They have nothing to do with this problem. 

O.k., are you adding the head to a new neck and then placing it on the body. If so, that's your problem. You need to use either the body's original neck OR the head's original neck. This isn't working because you always need a base mesh, which you don't have if you're attaching a head to a floating neck, hence the disappearing head. It's simply not attaching 'cause there's no base for it to attach to.

If that's not what you're doing, then the head's just not attaching. Try attaching to a different bone. I prefer to attach the head via the lower neck bone because most of those are useless anyway, and it'll leave the upper neck bone in good working order. And make sure you are attaching the head to the body and not the other way around, as the body serves as the base. If trying a different bone doesn't work, then make sure you're saving all changes you've made, such as armature adjustments. Also, make sure the body is at zero position (0.0.0) on the axis. I don't know why that makes the meshmods work better, but it does. 

Honestly, I haven't worked in XPS for a long time, so I can't remember all the tricks. But if it's not working, then you're doing something wrong. I know it's frustrating to hear that when you've tried everything, but it's the truth. XPS is a program coded and operated by math, and like math, there's only one way and only one answer. I do remember running into this problem a lot, but I always managed to solve it. It really just comes down to trial and error. That's the best way to learn the program and to fix any problems you encounter.
Reply
:iconfatslacker:
FatSlacker Featured By Owner Mar 20, 2015
Thank you for this answer! I must be doing something wrong 'cause this is the result. fatslacker.deviantart.com/art/…
Reply
:icon4wearemanytoo:
4wearemanytoo Featured By Owner Feb 24, 2015
Thanks for the tutorial! It has been quite helpful!
I have a question.
When I create a Meshmod, the neck is adequately fused with the body, but only the textures of either the head or the torso (not both) are shown. I learned both textures are named "main.png" so only one of them gets shown. What can I do?
Thanks in advance!
Reply
:iconaydean:
aydean Featured By Owner Feb 24, 2015  Hobbyist Digital Artist
You'll need to get this lovely little program known as Notepad++. Google it. The first result is the one you want. :] Open the mesh file for your model in the program, and you'll be able to rename all of the textures, which if done right, should fix your problem. You'll also need to rename the textures manually within the model's folder so the mesh file will know what textures to read when.

So, for example, here's one of my models cleaned up with all the textures renamed in N++ : clicky!. Each texture perfectly corresponds to each item on the model, from her bracelet, to her stockings, etc. Since N++ is a rather time-consuming program, you might want to just focus on renaming ONLY the two textures causing your problems. Also you'll need to rename all the sub-textures that go along with the main ones, like you have the "d" or "default" texture, which is the color, but don't forget to rename the lightmaps, bump maps (if the model has them), and any additional subtextures to ensure the model's mesh file can read them.

Last note: don't alter anything else in Notepad++. The simplest change, just like in XPS, can cause huge problems. Since your only problem is the names of the textures, just focus on that. 

Good luck!


 
Reply
:icon4wearemanytoo:
4wearemanytoo Featured By Owner Feb 25, 2015
Thanks a lot! Ill try this when I get home! Have a great day!
Reply
:icongothfemmerainbows:
gothfemmerainbows Featured By Owner Feb 11, 2015  Hobbyist General Artist
I've tried going over this tutorial over and over... and I connect my head to my model. I save it according to the tutorial's instructions. But when I reload my model, the bones are all there for the head, but it's not there. I can even go into the hide optional objects and the head's parts are all on the list, but it's a no show... any idea what's up?
Reply
:iconhypster83:
Hypster83 Featured By Owner Feb 9, 2015  Hobbyist Digital Artist
Hello, i don't understand well, but one of body stick to the other one? when you said rename? rename to what? Thank you.
Reply
:iconaddieredfield:
AddieRedfield Featured By Owner Jan 22, 2015  Hobbyist Writer
Thank u!!!! You saved my life ;)
Reply
:iconpm58790:
pm58790 Featured By Owner Dec 24, 2014
What you're gonna do when you a problem like this?
sta.sh/01bolxjnqh4g
Reply
:iconshaokahnsslavelilith:
ShaoKahnsSlaveLilith Featured By Owner Feb 13, 2015  Hobbyist Digital Artist
What did you do to fix this issue? I had the same thing ;(
Reply
:iconpm58790:
pm58790 Featured By Owner Dec 24, 2014
I think I got issue when the mesh modding. I got trouble putting the head onto the body. But it's impossible to put in the exact position.
Reply
:iconcawoow:
CaWoow Featured By Owner Sep 21, 2014  Hobbyist Digital Artist
GREAT TUTORIAL ^^ I have a question? where can I find the latest version from XPS? XNALara? or the update?
Reply
:iconxnaaral:
XNAaraL Featured By Owner Sep 23, 2014
You can find always the latest version from XPS
Reply
:iconcawoow:
CaWoow Featured By Owner Sep 23, 2014  Hobbyist Digital Artist
Ok thanks ^^ i will take a look there. ^^
Reply
:iconaydean:
aydean Featured By Owner Sep 21, 2014  Hobbyist Digital Artist
It's at XNAaraL's blog, which I always lose track of... usually, if you Google it, it'll pop up. 
Reply
:iconcawoow:
CaWoow Featured By Owner Sep 23, 2014  Hobbyist Digital Artist
Ok thank you very much i will take a look there ^^
Reply
:iconxnaaral:
XNAaraL Featured By Owner Sep 23, 2014
:lol:
Reply
:iconisobel-theroux:
Isobel-Theroux Featured By Owner Sep 12, 2014  Hobbyist Digital Artist
Great tutorial, it's really easy to follow :)

One question though after I attach the head and save it and everything when I reload the model, under optional stuff her head if listed, is there any way to fix this?
Reply
:iconaydean:
aydean Featured By Owner Sep 12, 2014  Hobbyist Digital Artist
Yes, if you get a program called Notepad++. Open the mesh's file in N++ and you're be able to rename to remove the (+) before the head's attached bone. Honestly, though, the fact that the head is shown with the (+) doesn't affect the model. The only reason you'd need to fix this is if it just annoys you personally. 
Reply
:iconisobel-theroux:
Isobel-Theroux Featured By Owner Sep 13, 2014  Hobbyist Digital Artist
Thanks I'll check it out :)
Reply
:icontdlballistic:
TDLBallistic Featured By Owner Apr 30, 2014  Hobbyist Digital Artist
Does this also apply to thighs/torsos?
Reply
:iconaydean:
aydean Featured By Owner Apr 30, 2014  Hobbyist Digital Artist
Pretty much. The bones you attach with will change, obviously, but it's the same basic principles. 
Reply
:icontdlballistic:
TDLBallistic Featured By Owner Apr 30, 2014  Hobbyist Digital Artist
How do I delete parts?
because right now I'm just smooshing characters together and it looks hellish.

shadowofanassassin.tumblr.com/…
Sent it to a friend cause it's her character I'm working on but, yeah
YOU CAN TELL I HAVE NO CLUE WHAT I'M DOING
Reply
:iconaydean:
aydean Featured By Owner Apr 30, 2014  Hobbyist Digital Artist
To do that, just follow this tutorial. You're basically going to tell XPS to hide the meshes you don't want to show by making those meshes "optional" and then having the program delete them. Follow the tutorial carefully, and it'll get you there. :] Be sure to reset all the posing before saving the models or else the meshmod won't work properly. 
Reply
:icontdlballistic:
TDLBallistic Featured By Owner Apr 30, 2014  Hobbyist Digital Artist
Tried to isolate Samus' head...
Everything went well, but after I saved it at a GenericItem and tried to add it into a scene an error message came up.
Reply
:iconaydean:
aydean Featured By Owner Apr 30, 2014  Hobbyist Digital Artist
What's the error? Try saving it again without the textures (then copy the textures over manually). That usually fixes many of the possible problems. 
Reply
:icontdlballistic:
TDLBallistic Featured By Owner May 1, 2014  Hobbyist Digital Artist
Loading model "data\Characters\Humans\Pan\Pan_Head\xps.xps" failed.
Could not find file 'E:\XNALara_XPS\data\Characters\Humans\Pan\Pan_Head\xps.xps'.

at System.IO._Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights

BLAHBLAHBLAH

You get it.
So try saving without textures?
Reply
:iconshaokahnsslavelilith:
ShaoKahnsSlaveLilith Featured By Owner Jan 30, 2015  Hobbyist Digital Artist
Did you get your issue fixed? Mine is still erroring out UGH
Reply
:iconaydean:
aydean Featured By Owner May 2, 2014  Hobbyist Digital Artist
Yep, seems the textures are corrupt and/or missing. Try saving without the textures and then coping them over manually. That usually solves the problem.
Reply
:iconcaxceberxvi:
CaxceberXVI Featured By Owner Mar 5, 2014  Student Digital Artist
every time i do this thehead that i add snaps to the bigger models root bone, is there any way i can fix this?
Reply
:icondidpedoted:
DIDpedoTED Featured By Owner Mar 5, 2014
May i ask is there a tutorial for why some models can't be mesh modded and make it available?
I notice some models that are already mesh modded i tried to like.....add a sunglasses to the models head and it turns up above her head(floating)Please reply ASAP=)
Reply
:icon972otev:
972oTeV Featured By Owner Feb 19, 2014
I have a little problem... k45.kn3.net/B/D/2/E/E/8/B8C.jp…

(i follow all the steps like the pic, and i put the upper neck, but that bone appears like a: unused head upper neck)

please tell me what im doing wrong :(
Reply
:iconresidenteebles:
Residenteebles Featured By Owner Feb 12, 2014  Hobbyist Digital Artist
OMG thank you so much for this!! it helped me to make my first ever OC! i cant stress enough the problems i was having but i got there in the end! im so proud of myself!

Reply
:iconaydean:
aydean Featured By Owner Feb 12, 2014  Hobbyist Digital Artist
Congrats! I'm glad the tutorials could be of use to you. :]
Reply
:icontony-antwonio:
Tony-Antwonio Featured By Owner Feb 4, 2014  Hobbyist General Artist
ok forget my last question. I have a new problem. now when I re-open the new model , the body from the head opens with new body. I can get rid of the heads old body by making it and optional item. but it 's still annoying every single time I open the meshmod...
Reply
:icontony-antwonio:
Tony-Antwonio Featured By Owner Feb 4, 2014  Hobbyist General Artist
ok, everything went fine, but now when I reopen the new model, and I bump up the Gloss, only the head shines and not the body... and I need the body to be glossy to show the color of it
Reply
:iconroughlight:
roughlight Featured By Owner Feb 3, 2014
Is there anyway i can edit the model texture to remain the same without using blender or 3dmax stuff?
Like my jill she used to be shiny when i first got her i just added a few items to her body and save generic item.She lost her texture
if it's not too much trouble could let me know there's a way to just copy,paste textures?
Reply
:iconserah-lightning:
Serah-Lightning Featured By Owner Dec 27, 2013  Hobbyist Digital Artist
Where can I download XPS ??? ;___;
Reply
Add a Comment:
 
×




Details

Submitted on
February 10, 2012
Image Size
4.2 MB
Resolution
1920×4384
Submitted with
Sta.sh
Link
Thumb
Embed

Stats

Views
25,664 (3 today)
Favourites
262 (who?)
Comments
223
Downloads
695
×